Connection timeouts in Remote Access and slow page response

Incident Report for Poly Cloud Services

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 19:15 MDT

Update

We are continuing to monitor for any further issues.
Posted Oct 03, 2025 - 15:17 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2025 - 13:15 MDT

Update

We’ve resolved the issue affecting page load times in the Admin UI. Our team is continuing to investigate the ongoing issues related to Remote Access and will provide further updates as we learn more. Thank you for your patience.
Posted Oct 02, 2025 - 17:49 MDT

Update

We are continuing to investigate issues within our message pipelines that are impacting service delivery, particularly affecting response times for Remote Access and the Admin UI page.
Posted Oct 02, 2025 - 14:27 MDT

Investigating

We are currently investigating this issue.
Posted Oct 02, 2025 - 07:44 MDT
This incident affected: Poly Lens.