Remote Access is unavailable for certain touch controllers

Incident Report for Poly Cloud Services

Resolved

The incident has been resolved. An underlying scalability issue in one of our IoT Hubs was identified as the root cause, which impeded the timely delivery of cloud-to-device messages and consequently resulted in remote access failures for certain devices.
Posted Oct 07, 2025 - 14:08 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2025 - 11:43 MDT

Investigating

A subset of the devices connected are reporting "Remote Access is unavailable because the device state is unknown"
Posted Oct 07, 2025 - 10:36 MDT
This incident affected: Poly Lens.